trensim.comSimulación Ferroviaria
   

¿Precisarían corrección los .eng de alguna Renfe 333?

Foro para tratar temas sobre ajuste y mejora de los parámetros de los archivos ENG y WAG

Moderador: Moderadores

¿Precisarían corrección los .eng de alguna Renfe 333?

Notapor factor » Mié Ene 21, 2009 2:58 am

Muy buenas.

Para que se entienda este hilo, necesariamente he de hacer referencia a un mensaje que está en otro. Concretamente a un mensaje en el que Blas_dani propone unos cambios en algunos parámetros del archivo .eng de la locomotora 333.062 (aunque sería aplicable al resto).

Este mensaje puede verse en este hilo: viewtopic.php?f=10&t=21594&start=15 .

He preferido no contestar en ese hilo y abrir otro nuevo (y en distinta sección) por parecerme más adecuado.

Pues bien, me he animado a experimentar las correcciones propuestas por Blas_dani y, yo no sé si atreverme a hablar de conducción más "fina", pero es evidente que solventa problemas que eran un tanto molestos como el de descarrilar por superar en 0,1 km/h la velocidad máxima permitida para ese tramo de vía.

Molesto no tanto por el hecho de descarrilar en sí, sino por irreal. Porque te recuerda que estás frente a un ordenador "cuadriculado" del que no puedes excederte ni un mínimo.

Ahora bien, sería interesante conocer la opinión de los autores que participaron en la parte técnica de la creación de las Rambos (creo que, si no todos, la mayoría son contertulios de este foro, como Jotaerre, Antuán, etc.).

Y digo que sería interesante conocer su opinión porque hay errores tan aparentemente absurdos (al menos para los no entendidos en informática) que se repiten en toda la serie de las 333 (no sólo en la 333-062 de la que habla Blas_dani), como es el caso de las ocho ruedas (este es quizás el más fácilmente observable de todos los mencionados), que quizás haya una explicación justificada para que el archivo .eng de toda esta serie de Rambos se haya elaborado así y no de otra manera.

En fin, igual que Blas_dani aportó su corrección (y personalmente, y por la parte que se refiere a evitar que descarrile la locomotora, se lo agradezco infinito), yo lanzo la siguiente pregunta: ¿alguien (coautor o no de las 333) ve, una vez expuestas las correcciones de Blas_dani, una explicación razonada a ese apartado de los archivos .eng originales?

Gracias por las posibles respuestas.

Saludos.


P.D: Por si sirve de referencia, lo que sí me he fijado, es que en algunas de las Rambos (por ejemplo en la última que vio la luz en la sección de descargas para MSTS el 27/12/2008 -la 333.089-) es que en dos líneas de los .eng, figuran los siguientes parámetros, que no concuerdan con los originales de otras:

DerailRailForce ( 2.5*120t )
DerailBufferForce ( 250kN )
factor
 
Mensajes: 388
Registrado: Sab Ago 30, 2008 12:16 am

Re: ¿Precisarían corrección los .eng de alguna Renfe 333?

Notapor Antuan » Mié Ene 21, 2009 4:36 am

Hola factor.

Ya que insistes, te voy a dar una respuesta, la mía. Siempre estaré de acuerdo en mejorar lo que tenemos, siempre que esté a nuestro alcance. En el momento en que se publicaron esas locomotoras, por lo menos a algunos, por razones que no vienen al caso, nos pilló al traspiés, y se quedaron cosas en el tintero. Por otro lado, al ser publicadas por partes, ahora es complicado sacar una versión X.2, ó como se llame, aunque sería lo ideal.

Si se publican las mejoras aparte, se forma otro lío (imagínate que ponemos las mejoras de la cabina por allí y las de los sonidos, por ejemplo, por allá ) aunque mejor eso que nada. De todas formas quizá se pueda hallar una solución para contentar a todo el mundo, pero yo no la tengo.

Saludos.
Visita de vez en cuando mi site: http://vapor3d.punchinout.net
Imagen
Avatar de Usuario
Antuan
 
Mensajes: 2642
Registrado: Lun Ene 31, 2005 6:22 pm
Ubicación: Siberia

Re: ¿Precisarían corrección los .eng de alguna Renfe 333?

Notapor blas_dani » Mié Ene 21, 2009 9:25 am

Hola:

El tema del ajuste de engs y wags es peliagudo. Por un lado, no hay una documentación clara que cubra todos los aspectos del eng, y además hay la complicación de que el motor del msts tiene algunas cosas mal paridas. Por otro lado está lo que comenta antuan.

De todas maneras, hay algunos ajustes que se pueden hacer fácilmente y forma metódica, como las bounding box, los enganches y estos ajustes de peso y fricción. Hay mucho material que deberia ser ajustado para en la realización de actividades no se produjeran comportamientos raros. Las técnicas que conozco estan en la trensimpedia.

Como dice Antuan, en el momento de construir un determinado modelo, se utilizan las técnicas que uno conoce y se aplican lo mejor que se puede y se sabe. Yo mismo, según lo que he ido aprendiendo, de mis modelos, le veo muchas deficiencias al eng del TRD, pero cuando lo hice me parecia perfecto.
Algunos cambios se pueden hacer y otros pueden llevar complicaciones...

Para el caso que nos ocupa, las 333, realmente no se porque la 333.062 descarrila tan facilmente. Posiblemente es por culpa de la linea
DerailRailForce ( 2.5*120t ) que tenia una y en vez de la t (claro despiste al teclear)... Apliqué la técnica cambiando eso y alguna cosas más y consideré oportuno hacer el comentario, aunque durante la realización de la actividad, he comprobado que al aplicar los cambios los frenos no funcionan demasiado bien... quizá por el peso excesivo del tren, o vaya usted a saber...

Muchos alaban el comportamiento de las 444 al conducirlas, eso me honra y demuestra que las técnicas que publiqué en la Trensimpedia funcionan.

Esperemos que msts2 venga con una implementación correcta de la simulación de las físicas y sobretodo con una buena documentación... al menos el flight simulator lo tiene por lo que msts2 seguramente también lo tendrá.

Saludos.
Avatar de Usuario
blas_dani
 
Mensajes: 2863
Registrado: Jue Sep 11, 2003 1:00 pm
Ubicación: Barri de Gràcia. Barcelona

Re: ¿Precisarían corrección los .eng de alguna Renfe 333?

Notapor factor » Mié Ene 21, 2009 1:17 pm

Muchas gracias a ambos, Antuán y Blas_dani, por responder.

Tu opinión sobre el asunto, Blas_dani, básicamente ya la conocía por haberla leído en el hilo que cito, y que fue el que me llevó a abrir este.

Y respecto a tus palabras, Antuán, no pedía ni tanta explicación (aunque siempre es de agradecer para entender mejor las cuestiones). Deduzco de ellas (aun a riesgo de equivocarme) que es probable que haya ciertos errores en esos parámetros de los .eng, y que el hecho de que figuren como figuran no responden a ningún criterio específico buscado a propósito por alguna razón (que es lo que preguntaba).

En lo que sí he de corregirte por erróneo es en esta frase:

Antuan escribió:Ya que insistes, te voy a dar una respuesta, la mía.


En los doscientos diecisiete mensajes -contando con este- que llevo escritos hasta el momento en este foro, es la primera pregunta que hago sobre este tema, así que no hay insistencia alguna por mi parte.

Lo dicho, gracias a ambos.

Saludos.
factor
 
Mensajes: 388
Registrado: Sab Ago 30, 2008 12:16 am

Re: ¿Precisarían corrección los .eng de alguna Renfe 333?

Notapor Antuan » Jue Ene 22, 2009 5:19 am

Hola.

Sí, es cierto que me confundí con el otro hilo y al leer el tuyo nuevo agregué tu observación a la de Blas_Dani. Es algo que pasa a veces al leer tantos mensajes en tan poco tiempo. Lo siento.

Saludos.
Visita de vez en cuando mi site: http://vapor3d.punchinout.net
Imagen
Avatar de Usuario
Antuan
 
Mensajes: 2642
Registrado: Lun Ene 31, 2005 6:22 pm
Ubicación: Siberia

Re: ¿Precisarían corrección los .eng de alguna Renfe 333?

Notapor via » Sab Feb 28, 2009 2:03 pm

He leido varios post sobre los .eng de la 333, pero soy incapaz de dar con la solución.
Me dan errores de linea 118, 124, etc, sobre la 333 rambo, 333020GL, etc.
Por favor alguien me podría pasar el archivo correcto a mi correo particular
Lo agradezco de antemano.
via
 
Mensajes: 44
Registrado: Dom Dic 05, 2004 3:53 pm
Ubicación: Lleida


Volver a Ajuste de ENG's y WAG's MSTS

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados